<!doctype html><html lang="en" prefix="og: http://ogp.me/ns#"><head><meta charset="utf-8" /><meta name="viewport" content="width=device-width,initial-scale=1" /><meta name="referrer" content="unsafe-url" /><meta name="twitter:site" content="@mic" /><meta property="og:site_name" content="Mic" /><meta property="article:publisher" content="https://www.facebook.com/MicMedia" /><link rel="apple-touch-icon" href="https://cdn2.bustle.com/2022/mic/icon-d9ec10ae77.png" /><link rel="alternate" type="application/rss+xml" href="/rss" /><link rel="preconnect" href="https://cdn2.bustle.com" crossorigin /><link rel="preconnect" href="https://imgix.bustle.com" crossorigin /><link rel="preload" as="style" href="https://cdn2.bustle.com/2022/mic/common-b0f4bf2471.css" /><link rel="preload" as="style" href="https://cdn2.bustle.com/2022/mic/CardPage-9569e779cb.css" /><link rel="preload" as="font" type="font/woff2" href="https://cdn2c.bustle.com/2022/mic/Obviously-Wide-cbf7b766a7.woff2" crossorigin /><link rel="preload" as="font" type="font/woff2" href="https://cdn2c.bustle.com/2022/mic/saintecolombeweb-regular-d93997639a.woff2" crossorigin /><link rel="preload" as="script" href="https://cdn2.bustle.com/2022/mic/main-651ee0c921.js" /><link rel="preload" as="script" href="https://cdn2.bustle.com/2022/mic/vendors-cc9dfbfc27.js" /><link rel="preload" as="script" href="https://cdn2.bustle.com/2022/mic/CardPage-8380f2bffd.js" /><link rel="stylesheet" href="https://cdn2.bustle.com/2022/mic/common-b0f4bf2471.css" /><link rel="stylesheet" href="https://cdn2.bustle.com/2022/mic/CardPage-9569e779cb.css" /><title>Emmett Till’s biopic is coming amid renewed scrutiny over the case</title><link rel="canonical" href="https://www.mic.com/culture/emmett-till-biopic-is-coming-amid-renewed-scrutiny-over-case" /><link rel="amphtml" href="https://www.mic.com/culture/emmett-till-biopic-is-coming-amid-renewed-scrutiny-over-case/amp" /><meta name="description" content="The first trailer for Till comes after the discovery of an unserved arrest warrant against his accuser and a leaked draft of her memoir in which she called herself a &quot;victim.&quot;" /><meta property="og:url" content="https://www.mic.com/culture/emmett-till-biopic-is-coming-amid-renewed-scrutiny-over-case" /><meta property="og:type" content="article" /><meta property="og:title" content="Emmett Till’s biopic is coming amid renewed scrutiny over the case" /><meta property="og:description" content="The first trailer for Till comes after the discovery of an unserved arrest warrant against his accuser and a leaked draft of her memoir in which she called herself a &quot;victim.&quot;" /><meta property="og:image" content="https://imgix.bustle.com/uploads/image/2022/7/25/40ada850-5205-45f3-b1d2-d270cdff21a7-intro-1658761215.webp?w=1200&amp;h=630&amp;fit=crop&amp;crop=faces&amp;fm=jpg" /><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="630" /><meta name="twitter:card" content="summary_large_image" /><script type="application/ld+json">[{"@type":"Article","@context":"https://schema.org","headline":"Emmett Till’s biopic is coming amid renewed scrutiny over the case","description":"The first trailer for Till comes after the discovery of an unserved arrest warrant against his accuser and a leaked draft of her memoir in which she called herself a \"victim.\"","datePublished":"2022-07-25T20:51:06.359Z","dateModified":"2022-07-25T20:51:06.359Z","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.mic.com/culture/emmett-till-biopic-is-coming-amid-renewed-scrutiny-over-case"},"image":{"@type":"ImageObject","url":"https://imgix.bustle.com/uploads/image/2022/7/25/40ada850-5205-45f3-b1d2-d270cdff21a7-intro-1658761215.webp?w=1200&h=630&fit=crop&crop=faces&fm=jpg","width":"1200","height":"630"},"author":[{"@type":"Person","name":"Brandon Yu","url":"https://www.mic.com/profile/brandon-yu-22630773"}],"publisher":{"@type":"Organization","name":"Mic","url":"https://www.mic.com","logo":{"@type":"ImageObject","url":"https://cdn2.bustle.com/2022/mic/logo-sdata-59e4fb102e.png","width":"118","height":"60"}},"articleSection":"Culture","creator":["Brandon Yu"],"keywords":["Movies","Social Justice","Criminal Justice","movies","culture","homepage"]},{"@context":"https://schema.org","@graph":[{"@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://www.mic.com/culture","name":"Culture"}}]}]}]</script></head><body><style>:root{--slot1:#000000;--slot2:#FFFFFF;--slot3:#F4F2ED;--slot4:#FCB159;--slot5:#3D312E;--slot6:#3D312E;--slot7:#3D312E;--slot8:#3D312E;--slot9:#FFFFFF;--slot10:#F4F2ED;--slot11:#FCB159;--slot12:#F4F2ED;--slot13:#000000;--slot14:#FFFFFF;--slot15:#3D312E;--slot16:#3D312E;--slot17:#000000;--gradientHalfOpacity:#00000088;--gradientTransparent:#00000000;--navColor:#3D312E}</style><div><header class="qU header-141076043"><style>.header-141076043{--metaColor:#3D312E}</style><div class="zU"><div class="zY"><a class="O3" href="/" title="Mic"><svg class="Po" viewBox="0 0 214 262" fill="none" xmlns="http://www.w3.org/2000/svg"><path d="M0 257.671L.394 4.331h28.994l18.499 133.557L65.86 4.33h29.257v253.341H66.517l7.61-159.929-17.319 159.929H38.31L20.99 97.742l7.61 159.929H0zM104.18 257.671V4.331h31.881v253.34H104.18zM143.27 219.623V37.653C143.27 17.057 159.144 0 178.43 0c19.549 0 35.423 17.056 35.423 37.654v83.965h-30.7V38.047c0-6.822-1.443-9.708-4.723-9.708-2.886 0-4.329 2.886-4.329 9.708V224.74c0 6.56 1.049 9.053 4.329 9.053s4.723-2.493 4.723-9.053v-88.689h30.7v83.572c0 30.044-14.169 42.377-35.423 42.377-20.991 0-35.16-12.333-35.16-42.377z"></path></svg></a></div><label aria-haspopup="true" class="V8 z1" for="navCheckbox"><span>Menu</span><button aria-expanded="false" aria-label="menu" class="CA" type="button"></button></label></div></header><div><article class="oV page-141076043"><style>.page-141076043{--slot8:#F4F2ED;--slot9:#FCB159;--slot10:#3D312E;--slot11:#3D312E;--slot13:#3D312E;--slot14:#3D312E;--slot15:#FCB159;--slot17:#3D312E;--strokeThickness:2px;--metaColor:#3D312E}</style><div class="cC"><div class="sW"><div class="JD"><div class="gs Ak"><header class="rO rR it"><h1 class="cS">Emmett Till’s biopic is coming amid renewed scrutiny over the case</h1></header><div class="r8 uR"><p>The trailer for <em>Till</em> comes after the discovery of an unserved arrest warrant against his accuser and a leaked draft of her memoir in which she called herself a &quot;victim.&quot;</p></div><div class="mp"><div class="hl dy"><picture><source media="(min-width:1025px)" srcset="https://imgix.bustle.com/uploads/image/2022/7/25/40ada850-5205-45f3-b1d2-d270cdff21a7-intro-1658761215.webp?w=1100&amp;h=800&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress, https://imgix.bustle.com/uploads/image/2022/7/25/40ada850-5205-45f3-b1d2-d270cdff21a7-intro-1658761215.webp?w=1100&amp;h=800&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;q=50&amp;dpr=2 2x" /><source media="(min-width:768px)" srcset="https://imgix.bustle.com/uploads/image/2022/7/25/40ada850-5205-45f3-b1d2-d270cdff21a7-intro-1658761215.webp?w=744&amp;h=476&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress, https://imgix.bustle.com/uploads/image/2022/7/25/40ada850-5205-45f3-b1d2-d270cdff21a7-intro-1658761215.webp?w=744&amp;h=476&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;q=50&amp;dpr=2 2x" /><source srcset="https://imgix.bustle.com/uploads/image/2022/7/25/40ada850-5205-45f3-b1d2-d270cdff21a7-intro-1658761215.webp?w=336&amp;h=215&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress, https://imgix.bustle.com/uploads/image/2022/7/25/40ada850-5205-45f3-b1d2-d270cdff21a7-intro-1658761215.webp?w=336&amp;h=215&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;q=50&amp;dpr=2 2x" /><img alt class="N4 ge" src="https://imgix.bustle.com/uploads/image/2022/7/25/40ada850-5205-45f3-b1d2-d270cdff21a7-intro-1658761215.webp?w=336&amp;h=215&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress" /></picture></div></div><span class="JX AK">Orion Pictures</span><div class="mF"></div></div></div></div></div><div class="OI"><div class="QV"><div class="WD">Culture</div><div class="lF FC"><span class="yF">By</span><a href="/profile/brandon-yu-22630773" class="NU">Brandon Yu</a></div><div class="KY"><div><time datetime="2022-07-25T20:51:06.359Z">10 hours ago</time></div></div></div></div><div class="tn"><div class="AO Af" data-adroot><p>The tragic story of Emmett Till is getting the biopic treatment. On what would have been Till’s 81st birthday and just weeks after his infamous accuser made headlines again, the <a href="https://www.youtube.com/watch?v=rkQi6GBwmSA" target="_blank" rel="noreferrer">trailer</a> for <em>Till</em> has been released, offering a glimpse into the story of the 14-year-old, whose 1955 lynching after being falsely accused of harassing a white woman shocked the country.</p><p>The early look is narrated by and told from the perspective of Till’s mother Mamie Till-Mobley. She became a prominent activist after Till’s death, and insisted his funeral be open casket to force the nation to confront the brutality of its racism. <i>Till</i> is an adaptation of Till-Mobley’s book and play <i>The Face of Emmett Till</i> and also follows <i>Women of the Movement</i>, an ABC miniseries from earlier this year that chronicled Till-Mobley’s life and activism.</p><div class="sW iG vr" style="max-width: 854px;"><figure class="VE"><div><div class="bw"><noscript><iframe src="https://www.youtube.com/embed/rkQi6GBwmSA" data-videoid="rkQi6GBwmSA" class="TV"></iframe></noscript></div></div><div></div></figure></div><p>The trailer comes after renewed scrutiny of Carolyn Bryant Donham, Till’s accuser, in recent weeks. In June, an unserved <a href="https://www.nbcnews.com/news/us-news/emmett-s-family-calls-womans-arrest-discovery-1955-warrant-rcna37125" target="_blank" rel="noreferrer">arrest warrant</a> that levied kidnapping charges against Donham, who is still alive, was discovered in a courthouse basement, prompting Till’s family and others to call for her arrest. (The district attorney declined to charge her.)</p><p>Soon after, a draft of Donham’s memoir, <i>I Am More Than a Wolf Whistle</i>, was <a href="https://www.nbcnews.com/news/us-news/emmett-s-family-refutes-claims-accusers-recently-leaked-memoir-rcna38391" target="_blank" rel="noreferrer">leaked</a>. In it, she claims that she had attempted to protect Till after her husband and other white men had kidnapped him and writes that she “always felt like a victim as well as Emmett.” She still insisted that Till had grabbed her waist after whistling at her in Donham’s family general store in Mississippi, an account that has been disputed for decades.</p><p>Donham’s husband and his half-brother were acquitted in a 1955 trial after Till’s body was found by boys fishing in the Tallahatchie River. The following year, in an interview they sold for $4,000, the two men admitted to the fact that they had tortured and killed Till.</p><p><em>Till</em> may reignite debates around what some see as a tired and potentially harmful over-emphasis on Black trauma in popular media. Nevertheless, the reignited controversy around Donham and the very fact that she is still alive and well is a jarring reminder of just how close in time the Jim Crow era is to modern America — and perhaps how stories like Till’s remain frighteningly pertinent.</p><div class="sW iG vr" style="max-width: 550px;"><figure class="VE"><div><div class="XU"><blockquote data-tweetid="1551611291650891776"><a href="https://twitter.com/thecindynoir/status/1551611291650891776?s=20&amp;t=sJOx7ECaoYM-j5Q9PlWcew"></a></blockquote></div></div><div></div></figure></div><div class="sW iG vr" style="max-width: 550px;"><figure class="VE"><div><div class="XU"><blockquote data-tweetid="1551616254590459906"><a href="https://twitter.com/Phil_Lewis_/status/1551616254590459906?s=20&amp;t=sJOx7ECaoYM-j5Q9PlWcew"></a></blockquote></div></div><div></div></figure></div><p> <i>Till</i> is slated for release in theaters in October.</p><aside class="x9 uM hI"><div><div class="lq"><div class="z3"></div><div class="FZ"><a class="vo" href="/culture/daniel-kaluuya-almost-quit-acting-jordan-peele"><div class="vZ"><div class="QV"><div class="WD">Culture</div></div></div><div class="yc"><div class="uQ"><noscript><img src="https://imgix.bustle.com/uploads/getty/2022/7/13/7a42935f-5177-42b3-a382-71a55948ccf6-getty-1239558671.jpg?w=118&amp;h=118&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress" srcset="https://imgix.bustle.com/uploads/getty/2022/7/13/7a42935f-5177-42b3-a382-71a55948ccf6-getty-1239558671.jpg?w=118&amp;h=118&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress 118w, https://imgix.bustle.com/uploads/getty/2022/7/13/7a42935f-5177-42b3-a382-71a55948ccf6-getty-1239558671.jpg?w=118&amp;h=118&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;q=50&amp;dpr=2 236w" sizes="118px" alt="British actor Daniel Kaluuya attends the 94th Oscars at the Dolby Theatre in Hollywood, California o..." class="Ed" /></noscript></div></div><div class="Ms"><div class="D-">Daniel Kaluuya says he almost quit acting before Get Out</div></div></a><a class="vo" href="/culture/keke-palmer-zendaya-colorism-nope"><div class="vZ"><div class="QV"><div class="WD">Culture</div></div></div><div class="yc"><div class="uQ"><noscript><img src="https://imgix.bustle.com/uploads/getty/2022/7/25/37067deb-04a2-4444-98fd-1a7bb06f8b0d-getty-1402716567.jpg?w=118&amp;h=118&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress" srcset="https://imgix.bustle.com/uploads/getty/2022/7/25/37067deb-04a2-4444-98fd-1a7bb06f8b0d-getty-1402716567.jpg?w=118&amp;h=118&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress 118w, https://imgix.bustle.com/uploads/getty/2022/7/25/37067deb-04a2-4444-98fd-1a7bb06f8b0d-getty-1402716567.jpg?w=118&amp;h=118&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;q=50&amp;dpr=2 236w" sizes="118px" alt="LONDON, ENGLAND - JUNE 13: Keke Palmer attends the Lightyear UK Premiere at Cineworld Leicester Squa..." class="Ed" /></noscript></div></div><div class="Ms"><div class="D-">Do we have to compare Keke Palmer to Zendaya? Nope</div></div></a></div></div><div class="lq"><div><div class="nn"></div><div class="BM"><div class="oH"><label for="email-signup">Stories that Fuel Conversations</label></div><form action="https://newsletter.bustle.com/signup" class="Ky" method="get"><input name="site" type="hidden" value="MIC" /><input name="source" type="hidden" value="OnDeck" /><input name="primaryNewsletter" type="hidden" value="micCheck" /><div class="n1"><input autocomplete="email" class="VU VU" id="email-signup" name="email" placeholder="enter your email address..." required type="email" value /><div class="yR"><div class="kj">I’d also like to receive:</div><div class="Gi"><input checked id="24027c08-779d-4565-00df-a7ba40ebe446-upNext" value="upNext" name="24027c08-779d-4565-00df-a7ba40ebe446-upNext" type="checkbox" /><label for="24027c08-779d-4565-00df-a7ba40ebe446-upNext">Up Next</label></div></div><button class="dM" type="submit">Submit</button></div></form></div></div></div></div></aside></div></div></article><div class="PQ h5"></div></div><div class="Jq"><input class="ec n7 wJ" id="navCheckbox" type="checkbox" /><input class="n7 wY" id="searchCheckbox" type="checkbox" /><nav class="za"><div class="K8"><div class="Yx"><div class="iz"><div class="xk"><svg viewBox="0 0 214 262" fill="none" xmlns="http://www.w3.org/2000/svg"><path d="M0 257.671L.394 4.331h28.994l18.499 133.557L65.86 4.33h29.257v253.341H66.517l7.61-159.929-17.319 159.929H38.31L20.99 97.742l7.61 159.929H0zM104.18 257.671V4.331h31.881v253.34H104.18zM143.27 219.623V37.653C143.27 17.057 159.144 0 178.43 0c19.549 0 35.423 17.056 35.423 37.654v83.965h-30.7V38.047c0-6.822-1.443-9.708-4.723-9.708-2.886 0-4.329 2.886-4.329 9.708V224.74c0 6.56 1.049 9.053 4.329 9.053s4.723-2.493 4.723-9.053v-88.689h30.7v83.572c0 30.044-14.169 42.377-35.423 42.377-20.991 0-35.16-12.333-35.16-42.377z"></path></svg></div></div><div class="Kj"><label class="V8 wV ny" for="searchCheckbox"><button aria-label="open search" class="CA" type="button"></button></label><label class="V8 wV BR" for="navCheckbox"><button aria-label="close nav" class="CA" type="button"></button></label></div><div class="v3"><form class="jI XD BL" action="/search" target="_top" autocomplete="off" autocapitalize="off"><div class="oK"></div><input type="search" placeholder="Search Mic" aria-label="Search Mic" name="q" class="X0" value /></form></div><label class="V8 gp" for="searchCheckbox"><button aria-label="close search" class="CA" type="button"></button></label><div class="iX"><a href="/newsletter" class="f0">Newsletter</a><a href="https://www.bdg.com/mic" target="_blank" rel="noreferrer" class="f0">About Us</a><a href="/current/masthead" class="f0">Masthead</a><a href="/archive" class="f0">Archive</a><a href="https://www.bdg.com/advertise" target="_blank" rel="noreferrer" class="f0">Advertise</a><a href="https://www.bdg.com/terms" target="_blank" rel="noreferrer" class="f0">Terms</a><a href="https://www.bdg.com/privacy" target="_blank" rel="noreferrer" class="f0">Privacy</a><a href="https://www.bdg.com/dmca" target="_blank" rel="noreferrer" class="f0">DMCA</a></div><div class="SV"><a class="aq" href="https://www.facebook.com/MicMedia" title="Facebook" target="_blank" rel="noreferrer"><i class="kS KU"></i></a><a class="aq" href="https://twitter.com/mic" title="Twitter" target="_blank" rel="noreferrer"><i class="kS Z1"></i></a><a class="aq" href="https://www.instagram.com/mic/" title="Instagram" target="_blank" rel="noreferrer"><i class="kS e1"></i></a><a class="aq" href="https://www.youtube.com/user/micmediavideo" title="Youtube" target="_blank" rel="noreferrer"><i class="kS bj"></i></a></div><div class="EN"><div class="fN"></div><div class="ur">© 2022 BDG Media, Inc. All rights reserved.</div></div></div><form class="eA" id="verticalsForm"><a href="/culture" class="fd"><span>Culture</span></a><a href="/identity" class="fd"><span>Identity</span></a><a href="/life" class="fd"><span>Life</span></a><a href="/impact" class="fd"><span>Impact</span></a></form></div></nav></div><noscript data-noscript><img src="https://pixel.quantserve.com/pixel/p-xPmcrFNGfHkBg.gif" /><img src="https://sb.scorecardresearch.com/p?c1=2&amp;c2=17519299&amp;cs_ucfr=0&amp;cv=2.0&amp;cj=1" /><img src="https://www.facebook.com/tr?id=1636673763227734&amp;ev=PageView&amp;noscript=1" /></noscript></div><script id="__INITIAL_STATE__" type="application/json" data-key="-560025608">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</script><script>__geo__={"country":"US","EU":false}</script><script defer src="https://cdn2.bustle.com/2022/mic/main-651ee0c921.js"></script><script defer src="https://cdn2.bustle.com/2022/mic/vendors-cc9dfbfc27.js"></script><script defer src="https://cdn2.bustle.com/2022/mic/CardPage-8380f2bffd.js"></script></body></html>